Cannot create MyQ connection

I am not able to create a connection to MyQ.  I get unknown credentials every time.  Have absolutely confirmed my credentials.  Have tried both on the app and the web interface from PC.  Am I doing something wrong?

5

Comments

106 comments
  • I have the same issue. Looks like the API has changed

    3
  • Same myq login creds not working. I submitted a ticket, will see where it goes.

    3
  • Yup. Mine stopped working as well yesterday. When I went into Add Remove Items and into Manage Items, there was a message under MyQ openers confirming there was an issue and to delete link and re-add it. I did delete just the MyQ connection with no joy. Deleted full Simple Commands app and retried with a new download from Play Store with no luck.same issue with "Invalid credentials, please try again. I guess it is a known SC Problem.Hoping we get a fix soon.

    3
  • Same problem, looks like Chamberlain changed their API.

    It’d be nice if SC sent out an email to their users letting them know there’s an issue instead of all their users trying to figure out the issue.

    I’m sure everyone here deleted their devices and will need to recreate all their routines and Alexa links. That’s unnecessary and could’ve been avoided with a simple email.

    3
  • If you are good at following instructions check out https://github.com/rjcohn/alexa-pymyq. He did a wonderful job and included all the code and exactly how to set it up. I am back up and good to go thanks to his instructions and whoever here in one of these myQ threads pointed me there. And this method should only cost you about 30 minutes.

    3
  • I was getting the same thing. I found the fix. 

     

    When you click on add a connection DO NOT SELECT MYQ, Instead you need to select the one that says Generic Garage Door Opener. It will ask for you MyQ login 

    2
  • I also do not see the 'other' garage door opener, and I have confirmed my credentials for MyQ is correct (even using copy/paste). However, I still get the invalid credentials error every time. Is there something I'm doing wrong? Have folks solved this since the last post?

    2
  • David Jones, thanks for the confirmation. Hopefully, something can get fixed. I just got the MyQ on the Amazon Treasure truck, now I'm wondering why they would promote something that works with Google, and not Alexa, even if it was through SC

    2
  • I am having the same problem that Kevin Lavigne mentioned

    2
  • Same problem as described above.

    2
  • Got word back from support - I'll wait for their fix.

     

    Sorry for the troubles.  
    The myq auth api has changed. 
    We have the fix working in dev and will have the fix
    moved to our production servers by Mon/Tues at the latest.

    2
  • Mary Higginbotham

    Same thing here - at least its a sign that they're working on it.

    2
  • Something has changed.

    When I add an Item, MyQ, it accepts the ID and Password, and the pop-up states "Connection Added Successfully, Click on connections list to see new items".

    But here's the problem, I don't see the connections list or any list with the MyQ.

    2
  • I'm not sure how this subject got highjacked by Alexa command issues, but the original subject is 

    "I am not able to create a connection to MyQ.  I get unknown credentials every time.  Have absolutely confirmed my credentials."

    This is still a problem, this has nothing to do with Alexa commands. 

    2
  • I have the same issue and unable to login to MYQ from simple commands to setup a connection. Anyone suggest what we are doing wrong

    1
  • Still not able to login or sync with any of the chamberlain or myq  credentials. I do NOT know what else to do to get this to login or sync - please help

    1
  • Paul Chapman it looks like MyQ may have changed the API so SC no longer connects. Just started today. I deleted the MyQ connections after clicking on fix (which did nothing) so followed the suggested delete/re-add and receive the same error that you do.

    1
  • Same here, SC cannot connect to MyQ using known credentials.

     

    1
  • Getting a different error message today.

    1
  • Thanks Ron G

    1
  • Thanks Ron G 

    1
  • I also went from the invalid_request message back to invalid credentials message just now.   We need to get the MyQ link back!!!

    1
  • Ron G, please see my previous post about geofence and Shortcuts. (I think four above.) Follow Cory Schmaltz link above to get Shortcuts already made on Reddit. If you use those you will have to change the API as noted. This is a good guide for starting with Shortcuts. It's not free, however. https://learn.macsparky.com/p/shortcuts13

    1
  • Yup. Also sent an additional query and crickets. For some reason, SC must be having a more difficult time with the new API

    1
  • I haven't got support from SC nor Chamberlain, perhaps it was wasted time and money with myq.  So I ordered this:

    Amazon.com: Smart Wi-Fi Garage Door Opener, Compatible with Apple HomeKit, Siri, Alexa & Google Assistant, No Hub Needed, Wireless Remote Control: Electronics

    1
  • I'm not giving up on SC. They've always addressed the issue before when the MyQ API changed. They also reported that they had the current API working in their Dev environment. Their service is free and has been working for quite a while all at no cost. It does suck that my doors don't close when I leave or open when I return, but when it works, it's great so... 

    1
  • Wish there was an ETA for this fix too. Been trying to connect SC to MyQ every day in hopes that the issue got fixed but no joy for now. Really looking forward to this fix.

    1
  • I also seem to have a new fix, complete with non-interaction geofencing. It involves using Samsung SmartThings with Alexa (before, I was using SimpleCommands with Alexa for non-interaction.) It was not easy nor intuitive unlike Mary's description above. But, it does seem to be working (will report back if not.) The instructions are here: http://thingsthataresmart.wiki/index.php?title=Community_Installer_(Free_Marketplace)#Installation . As a caution, I will add it takes patience for everything to show up in the SmartThings app. 

    1
  • I used a custom Alex skill for a few years before finding SC. I'm still hopeful that SC will resolve the API/Login issue so I'm just going to wait it out. I have routines written for a 3rd party app that close both doors when I leave and open the door corresponding to the car I'm driving which I've only been able to get to work with SC. Glad everyone is able to come up with options though!

    1
  • Still can't create a connection to MyQ. It just asks for login info and refreshes the screen with nothing there. When developers said they had a fix going to production on "Mon/Tues at the latest" (on July 16th) which Mon/Tues were they talking about? 

    1

Please sign in to leave a comment.

Didn't find what you were looking for?

New post