Cannot create MyQ connection

I am not able to create a connection to MyQ.  I get unknown credentials every time.  Have absolutely confirmed my credentials.  Have tried both on the app and the web interface from PC.  Am I doing something wrong?



  • Steve , only simple commands can fix that one. MyQ keeps changing their APIs. People are just offering other workarounds such as Alexa skill.  Personally I will not go back to SC after seeing how easy the Alexa skill was to setup.

  • @Tim I don't have Alexa and never will. I need this to work for other reasons, although it looks like it is an ongoing issue so I suspect I'll need to uninstall this (cr)app and work around it another way 

  • Ok I have gone through ALL the steps again from the beginning, all the code & tests show successful w/0 errors. And yes this is a new download of the Code ZIP file. I labeled it as "my garage" even the my q app name for the device is "my garage". Alexa Dev Console > per the example "

    Alexa, ask MY GARAGE if DOOR is open


    now i get - The requested skill did not provide a valid response

    suggestions of what to try now?

  • Cory what happens is you just say or type "Alexa, my garage"  

  • same error - " The requested skill did not provide a valid response"


    HelpIntent & TestAllStates both pass the "tests" portion

  • Please check where your skill is defined under invocations and make sure Skill Invocation Name = my garage . Mine seemed to have gotten overridden.  And you made sure your endpoint pointed at the AVN of the lamda instance?

  • Yes, I have verified the invocation name is "my garage" I even added an "S" saved it then removed the "s" just now. Yes the copy ARN from the console is pasted into the Default Region (no others), per the instructions.

    what else would you like review over/verify?

  • I assume you are using build model after making each change.   You were running the old code then upgraded.  Did you blow away the previous Skill and lamda instance or just re-upload the zip file to the code? In my case I blew away everything and started from scratch.   If that doesnt work I would look to enable debug logging in the environment variables , try running some commands, then look at the cloudwatch logs.  In the doc it explains how to do that.

  • Confirmed - by going back and deleting the original skill/build and starting over it appears to be working with the Alexa test console! I only have 1 garage door so the 2-door doesn't apply for me. -- Of Note I was on the phone with Chamberlain (my mfg. opener) cause it lost its brains last night and we redid things with the motor to relearn and redid all the PINS also. I DOUBT this was a variable over the developer/AWS portion. But if finally works how i wanted it too for this part at least - How COOL! thanks everyone!

  • Today I'm getting "Invalid credentials please try again" when attempting to add MyQ -

  • I am getting a response from Alexa saying there was an error processing my request, since I updated to the new code on github, anyone else getting it, it was working great yesterday but not now.

  • UPDATE. Now able to connect to myQ Openers. Everything shows up fine and syncs OK per app, Have deleted and reinstalled all routines which allow you to pick options for each door and show as active, but Home Status shows both doors Offline. Alexa responds she has found more than one item called" OPEN GARAGE DOOR" when asked to TURN ON. Looks like the work is continuing. 

  • Kevin Lavigne, interestingly, my iPhone shows my door offline as well. On my iPad, however, I can open and close the door from the All Items screen but NOT from a routine. I've sent a message to SC but so far, no response.

    I believe MyQ/Chamberlain has changed something, again, because routines in Alexa, SmartThings and Siri Shortcuts also do not work. The only way on my iPhone I can do anything is through the MyQ app.

  • Thanks for the heads up Kevin Lavigne 

    I added MyQ and it shows up in the list "All Items" and I could configure Geofencing Routine, but status is showing offline.

    If I Execute the Routine is gives and error "Something Went Wrong - try again...".

    My iPhone's MyQ app is giving change of status alerts and shows online - the Ring app also shows the correct status.



  • Its working again.

    Well done to the SC development team for this.

    Can command Open & Close and Geo-fence.

  • I can confirm, It is now connecting and alexa will open and close each door. The only problem I have is Alexa tells me for example " Open Garage door one " is not responding, but she opens the door anyways. same response with all commands, I have deleted and readded all routines to Simple Commands , Synced and verified scenes in  Alexa even rerunning discovery and then deleting duplicate scened but still the same response. Not a big deal, but if anyone has any ideas on how to fix this, it would be appreciated..


Please sign in to leave a comment.

Didn't find what you were looking for?

New post